MōVI Stabilizer Commonly Asked Questions

I asked question I thought you guys might ask.

Testimonial-1

My friend James Drake invited to a shoot, he was using his Red Epic and they were also using a MōVI stabilizer, I thought it would fun to see it in action and ask a few of the most commonly asked questions along the way.

I can’t afford one of these and I figure most of my audience can’t either ($15k), so when I sat down to ask them questions about it I tried to keep it as generic as possible, so when the less expensive models start being more popular this video might be helpful to you guys.

The shoot took place inside a recording studio in Denver, directed by Wade Yamaguchi who I didn’t get to talk to much since he was so busy. I mostly spoke with Seth Schaeffer of Hoptocopter Films and Cory Reynolds of Contrast who operated the Movi.

They let me copy the footage from the shoot and share it here in my video, I gotta say it looks very smooth when you compare it to my horrible Glidecam skills. I can tell you I am not Devin Graham if you know who he is. Devin is a freak of nature on how he can operate a Glidecam device. While it is a lot better than a Glidecam I could still sense the walking footsteps.

When the stabilizer has a wireless feed for the video, and a follow focus, it gets complex fast. And to adjust the balance doesn’t seem to be the type of quick adjustments you would find on a Glidecam.

Common Questions for the MōVI

  1. How to you light your talent while they are moving?
  2. How long it takes to re-balance the rig after a new lens is put on and when you balance it for the first time on set?
  3. What equipment they were using for the shoot?
  4. What is the Movi used for; narrative, docs?
  5. I also asked about action sports?
  6. How long can you hold it before your arms give out?

Interesting that this device is most needed for amateur’s like myself because it takes months of practice to do the Glidecam/steadycam well, but the price is not an amateur price.

Note to myself: I kept getting a rendering error within Premiere Pro, Unknown Error, I tracked it down to a C300 clip at the end of the video, it was failing at 47%, I keep rendering sections until I found the bad clip and then Premiere Pro rendered it out without an issue. Next time it errors out and using 2-pass that is where the bad clip is located, percentage wise. Also I think I have a red hot pixel on my 5D3 at high ISO’s – center top.

Royalty free music by PremiumBeat.com

Products Used In This Video – Find Prices

Help me make more of these types of videos by purchasing gear from the links posted on my site. It costs you nothing extra, and helps support me to make more videos.

5D Mark3

5D Mark III